WIFI won’t restart

I powered down my node but now DappNode Wifi won’t restart. I’ve only got access to Admin when DappNode wifi is working. How do I restart Wifi without the admin page “restart wifi”? I do t know why wifi didn’t restart.

Just restart the Node again, I’ve experienced this a couple of times, restarting the node usually gets the WiFi up again

1 Like

For security reasons DAppNode has changed the restart policy of the wifi container, so if it is manually stopped it will not restart after rebooting.

There are 3 different ways you can try to restart the wifi package:

  1. Try what poolisa01 said
  2. Connect to your DAppNode using hdmi and keyboard, go to the admin packages view and restart the package.
  3. SSH into your DAppNode:
    3.1 Once inside your DAppNode set the command docker ps -a and copy the wifi container ID.
    3.2 Execute the command: docker start <wifi container ID>

I suppose this explains why just powering on again won’t start my wifi. Now I’ve got to work out what you mean.
I’m still having problems with my internet connection going on and off today 120 time so far. I posted that in another post. Telekom engineer coming in the next few hours for the 5th time :roll_eyes:

1 Like

Hey @Blackswan - did the trouble with the internet start when you installed your dappnode?

I’m not sure about the time line. I disconnected it for two days and all was fine. Then I reconnected it and all was fine for 19 hours and then I started getting lost internet and then many DSL reconnects. I’ve tried everything and will shortly be abandoning Validating with DappNode if it doesn’t work soon. I’ve invested many many hours trying to get OpenVPN working… no luck. It attests well for a day then goes off… I’ve unplugged the router let the cache empty replugged. Goes ok sometimes… then the internet goes off and then the DSL reconnects again.
Avax had same problem with “residential routers” and introduced a fix… that killed the problem. I opened a ticket here but as yet no reply.
I’ve had Telekom engineers here 4 times and one is supposed to arrive again today… between 13:00-18:00… each time they do exactly the same thing. One engineer doesn’t know what the other did… one said the cables weren’t good and he would call the underground crew… the next engineer came into the house again. Nothing was done outside.

There might be a problem with P2P connections from IPFS - has happened to other people.

If you can connect to the DAppNode via WiFi hotspot or any other way, could you go to the dappstore and type ipfs.dnp.dappnode.eth - press enter - let it load and install the newest IPFS version.

Then go to the IPFS package (Packages > System Packages > IPFS) and in Config you will have a drop-down menu in which you will be able to put IPFS in low power mode. If it is IPFS as it was in other cases, this should solve it.

i have had trouble restarting my wifi after the latest wifi 0.26 update

1 Like

It seems like there have been a few users experimenting problems with the wifi service since the last realese.
The wifi service was updated from version 0.2.5 to 0.2.6 If you have VPN setup then connect to your DAppNode and check the wifi service by going to packages > system packages > wifi

  • Probably you will have the wifi service with the status stopped .
  • In the logs section you may have the error “interface not found”

You can solve this by:

  • Press restart option for the wifi service
  • If you do not have access to your DAppNode then reboot your DAppNode OR connect via ssh and restart the wifi package (only recommended for tecnical users): docker restart DAppNodeCore-wifi.dnp.dappnode.eth

Thanks for this! I’ll look into it. I’ve had countless other problems but slowly getting acquainted. Why low power mode? What will that do?

Updated… to new Wifi… tried restarting from reboot. Option 1 and 2 can’t get to work. I have SSH but can’t understand where too look. Sometimes too much prior knowledge is assumed I’m afraid. May I have a little clearer instructions please.

Option 2 how do I find Admin package in command line. This is what I’m afraid I mean by assuming everyone knows exactly what you’re on about. You are Linux gurus some of your audience aren’t… that’s WHY I chose DAppNode and also Grant DAI often.

I pasted „docker ps -a“ into ssh but couldn’t find anything with WiFi ID… am I looking in the Right Place?

Update I googled… docker images… that bought up an id next to Wifi 0.2.6 an 11 fig number set. Then I pasted „docker start with the number…“. result error.

@Blackswan Is fine, you are right you should do not need to have technical knowledge to use DAppNode

Rebooting your DAppNode shoulder be enough to make the wifi service work again. If that did not work just paste the following command in your terminal: docker restart DAppNodeCore-wifi.dnp.dappnode.eth

Anyway I am trying to reproduce the error so I can give you better support about this issue

Ok that worked straight away. Thanks. One question… why set IPFS on low power Mode? Why does normal mode create a problem?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.