VPN download URL / file

Hello community!

As I am trying to set up my node for staking, I ran into the following quote in Dappnode’s documentation when trying to get Tunnelblick up and running:

Once you have your DAppNode running, you will get an URL in your terminal from where you can download the OVPN config file and open it in your device with your OpenVPN client.

Is the URL the link from the system’s VPN package? And if so, I am redirected to Gitub, but there is no .ovpn file that I can download?

Basically, I do not know where I can find this file to drop into Tunnelblick to get it running…

Thanks for your info!

Hi @Dapper and welcome to our community forum!!

Just go to http://my.dappnode/#/devices and add a new device there. Set it as admin, and click on get the link

Thanks for your quick reply, ruvenni!

Unfortunately, when opening this given link, it gives me the “address unreachable” error, so I do not see anything. I have disabled my normal VPN and Tunnelblick.
Any suggestions?

That’s a connectivity problem regarding your router config or ISP policies. The VPN needs port 1194 UDP and 8092 TCP.

You can enable UPNP in your router config - to let it open those ports when needed - or you can set the ports open manually in your router configuration (usually under NAT or Port Forwarding options). Some ISPs won’t let you open them easily even though.

Thanks ruvenni!

I checked my router, and it has UPNP enabled. I can connect to my home network. I can connect and surf using the dappnode network. ports 1194 and 8092 are open. Running diagnostics says all is green…

Here is a screenshot from my system

Then it should work but I don’t trust routers firmware or ISPs configurations. Mine says ports are opened but they are not.

You can try to access the ‘get link’ when connected to your router’s wifi instead of the DAppNode WiFi hotspot and let me know if that works.

You can also use an external tool like check-host to verify if port are open correctly:

  1. Copy your url link (the content of the blue highlighted box)
  2. Go to check-host and paste it there
  3. Click on TCP port

Do the same three steps but removing :8092 and adding :1194 instead plus clicking on UDP port button.

Great tips you got there!

Opening the link via my regular network brings nothing to the table unfortunately. The reason could lay in the following:

The TCP test comes back as “connection timed out”, whereas the UDP states “open or filtered”.

So I presume the TSP does not work properly?? Do I have to open this gate manually? When doing so, what do I have to watch for in order to not compromise security?

Thanks for your efforts!

I’m afraid you are right and you will have to research how to do it depending on your router config / manufacturer and / or ISP policies. If you don’t succeed you will not be able to use the VPN connection, but only the DAppNode WiFi hotspot connection.

Worst case scenarios could be having to change your Internet provider or setting your router in bridge mode, buying another router and put both to work together.

Always very glad to help!! :wink:

Let’s try and work this out

@ruvenni and @Dapper this was super helfpul and I checked my TCP and UDP. The TCP came back as “Open” and the UDP came back as “open or filtered” one of the UDPs came back as “unknown host”. I still can’t connect to recieve the ovpn download. Do you think its an ISP think for me too or is “open or filtered” ok? I also checked my ISP and they do block some TCP and UDP ports but not 8092 and 1194.

Update: I used port forwarding to open up TCP 8092 and UDP 1194 and now it looks like the browser is attempting to access the URL but eventually I get a time out error - " *********.dynds.dappanode.io" is taking too long to connect.

Any ideas @ruvenni?

Update: I moved to a ISP provider and that did the trick… Xfinity does not seem to be friendly to this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.