SSH Credentials for pre-installed DAppNode


I am trying to SSH to my DAppNode which I received pre-installed, but can’t find the credentials anywhere. I tried both dappnode and root logins without password and it is rejected:

$ ssh dappnode@<local IP>
dappnode@<local IP> password: 
Permission denied, please try again.

Can you please advise what is the pre-configured password?

Thanks and regards

Hi @mta and welcome to our community forum!!

You should not need to ssh access to your dappnode. Not at least for setting it up right after the unboxing.

Please, read the attached thread and remember to use the search before asking anything if you are so kind to :wink:

PS: Setting up instructions come in a brochure inside the package, with the NUC and cables. Can you please confirm you receive them? Thanks!


Thanks for the answer, appreciated.

I did made a search on the forum and found the above post, but it was not clear to me this was related to SSH or shell access. I tried blindly with the wifi password since I did not remember having set a password at first connection and it was not working, thus my post.

Fortunately I was able to remember the password I had set initially and was able to login over SSH. If I can suggest something would be to warn users to write their password down or have it in a password manager since they might lose it forever…

To give some context, I did receive the brochure and it was all very straightforward to install and setup (great job!), but I wanted to double check that NTP was activated since I could not find this information in the user interface.

Again thanks for the great product, love it, and my ETH2 validator is working perfectly.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.