Dappnode interfering with local network

Hi all,

Started playing around with dappnode this week. But I’m encountering a network connectivity issue.

Ever since the node is spinning with Onyx Beacon chain and validator the local network is suffering. Low transfer speeds to no connection at all on other devices in the network.

I’m running a nuc10 i5, 16gb ram and 1tb sad with Ubuntu and dappnode installed. Packages installed are: dms, ethstats, göeth, onyx Beacon chain and onyx validator (not activated yet).

The nuc is hardwired directly into the router. Ports are open and I can enter the dashboard trough vpn.

What can I do to stabilize the network connectivity?


@Edu, is that what happened to you too? Did you figure out what it was?

1 Like

Yesterday I rebooted the NUC and added the Dappnode VPN file to Ubuntu network settings. That seems to make it more stable.

This morning I had connectivity issues again so I checked the network settings and the vpn wad turned off in Ubuntu. Switching it on did the trick again.

1 Like

No luck. The network keeps clogging to a level on which other users can’t use a proper internet connection. So I stopped dappnode eh rebooted Ubuntu and now I’m going to try a Beacon mode and validator outside of dappnode.

1 Like

I’m probably way over my head here, but the VPN file is supposed to go in another machine in order to access the admin UI, i.e.: your laptop or your phone.

That said, the network congestion shouldn’t happen. If you don’t run the Beacon node it’s fine?

It was worth a try but you are right. The VPN in the dappnode machine didn’t work.

Running a prysm Beacon chain and validator apart from dappnode os works just fine. I can even run a local eth 1 node and still no signs of network congestion.

Limited beacon node peers to 10 tough.


@Noxa did you end up finding a solution using dappnode?
I am having the same issue. Rebooting/system restore clears up the network for a few hours before internet connection for local users slows and then stops.

No I haven’t. I removed dappnode and installed Ubuntu. Running 2 Beacon chains and a set of validators with Lighthouse & Prysm. All runs smoothly and I learned what’s happening on the backside of those docker containers.

I’m waiting for a updated version of dappnode that will support the nuc 10. Will definitely try that it again.

1 Like

Continuing this thread. I ran a full node with validators on the dappnode basic with no issues for about two months. I upgraded to a dappnode advanced NUC 10 and since then have had the same network problem that Noxa does above. Bandwidth metrics look good and from what I can tell the problem is unrelated to IPFS or the router. Would appreciate any troubleshooting tips or ideas!

1 Like

Putting a couple of tweets here that hint at some network problems too. Not that I know what they can be caused by :sweat_smile:, but for aggregating similar problems

1 Like

I did experience similar network problems a while back (like Noxa I was running a NUC with Ubuntu + DAppNode). Other devices on my local LAN would become unresponsive. I traced the problem to TCP/IP v6 because I was seeing many odd entries on my router logs relating to it. Disabled IP v6 addressing in Ubuntu and the problem resolved. I never really identified what was going on though.
I have since re-built my NUC and didn’t include any IP v6 change but all has worked fine since!..so I never got to the bottom of it. :man_shrugging:


Is it possible that the slowdown is linked to the dappnode advanced NUC10? It seems many of the folks having LAN trouble are running on the advanced or a NUC with the same specs.

I switched to a remote node and the network issues went away.


I’m seeing something similar, NUC 8 attached to LAN causing issues for the other users.

I’m trying to limit the bandwidth to the NUC to see if that helps.

OK, limiting bandwidth didn’t work (Geth, GoGETH, Prysm beacona dn validator). High memory use, unresponsive, and screws my internet.

I’ve tried removing IP6 permisionins on the Unbuntu 20.04 install that my DappNode is sitting in.

OK, I’ve been doing some trials:
NUC 8 running Ubuntu 20.04 with Dappnode on top.
LAN cable direct to Router.
Router is throttling the NUC to 7 Mb/s via LAN (and Wifi)
IP6 is disabled on Ubunto.

I’ve been setting the Dappnode to synchronize overnight and then run. If there are network issues during the day, the node is turned off

  1. Geth, GoGETH, Prysm Beacon and Validator - Fail
  2. Geth, GoGETH, Lighthouse Beacon and Validator - Fail
  3. Geth, GoGETH, - Fail
  4. GoGETH - ok

I’m going to leave GETH off and try the beacon chains and validators.

Core DAppNode Packages versions

  • dappmanager.dnp.dappnode.eth : 0.2.34, commit: d075b2f5
  • core.dnp.dappnode.eth : 0.2.38
  • wifi.dnp.dappnode.eth : 0.2.3
  • ipfs.dnp.dappnode.eth : 0.2.10
  • vpn.dnp.dappnode.eth : 0.2.6, commit: e0d9c111
  • bind.dnp.dappnode.eth : 0.2.5

System info

  • docker version : Docker version 18.09.8-ce, build 0dd43dd87fd530113bf44c9bba9ad8b20ce4637f
  • docker compose version : docker-compose version 1.25.5, build unknown
  • Disk usage : 36%
1 Like

Any updates on this @overanalyser? Have you managed to sync?
I would try one by one. If you use “remote” to access the DAppStore, try with only GoGeth and after it’s synced with ONE beacon chain?

I can sync, but the network grinds to a halt. Even when only running GoGETH (no beacon or validator running, remove GETH).

I’ve had a break for a few days.

I’ve noticed that my ISP download drops from > 100 Mbs to ~20 Mbs and I think it’s related to the ISP detecting the peer to peer connections

Current plan is to:

  1. try routing the Nuc via a VPN.
  2. Try a fresh install of Dappnode (without Ubuntu installed) via lan cable- mainly to try and fix the VPN connection issue.

ive got this same issues on a NUC10 - have not found a solution


My original problem was using ubunto 20.04 with Dappnode on top (because direct install of DappNode would stall at the VPN). I was installing everything using wifi, then moving my NUIC to nect to the router and using LAN cable once I had the VPN / remote desk set up.

Recently I installed using the ISO and connecting to the router via LAN cable and I got the VPN code, and it appears to have solved the LAN issues.

My ISP varies form 150 to 20 MBs download, but I’m not seeing interference with the other users ont he Wifi.

So, It looks like full ISO install using LAN only for the connection solves everything.

I’ve just switched everything over for the rocketpool beta, but will try a longer test on DAppNode soon.

1 Like