Dappmanager 0.2.35 can't open ports natRenewal errors

Hi all,

Anybody seen an error where dappmanager cannot open any ports?

It says UpNP device available but there is nothing under the currently configured UpNP ports.

Ports 32768, 32769 8092, 1194, 4001 and 4002 can’t be opened by the dappmanager. Restarting doesn’t help.

I have almost synced geth and i really don’t want to have to nuke this install.

I can’t get to the dappstore to upgrade dapp manager.

I tried to upgrade dappmanager but going to http://my.dappnode/#/installer/dappmanager.dnp.dappnode.eth brings me to an endless waiting page and the dappstore is empty. Also ipfs is empty when viewed through the webui

A similar failure happened to this user, but for them the dappstore was working

I am also getting 100% NAT LOOPBACK packet loss. Trying to figure out where to enable that on my router.

Doing ss -tulpn shows ports 68, 32768, 32769, 1194, 4002 are unconnected on udp and 12287, 8092, 12287, 23768 and 4001 are listening on tcp

The command that is failing is trying to open a port using universal plug and play which is enabled on my router

When i tried to do the same command from the command line it says my router supports only permanent leases. I also had to apt-get the upnpc because it wasn’t available outside the docker container

Best regards

Hi @jin

You say your DAppManager is at v0.2.35 but latest is v0.2.37, are you able to update?

You can also try a manual update from the terminal with wget -qO - https://installer.dappnode.io | sudo UPDATE=true bash

I was not able to update due to the ports not being able to open and also a failure to get nat loopback.

I will try wget now

EDIT: The script that wget fetched is running now and is fetching packages. Hope the install succeeds

Hi Jin,
I too have these errors and can’t seem to figure out what the issue is. I have changed the NAT filtering from secured to open on the router to no effect. The good thing is however that although I have these errors my Dappnode appears to Validate on Eth2.0 okay.

very similar to what I see as well

The UPnP port map table on my router doesn’t show any mappings for the Dappnode either which is strange. It does for other devices.

The manual update script failed for me

What kind of linux distro are you installing DAppNode on top of?
May docker version is not very up-to-date?

Maybe you can run sudo apt-get update and
wget -qO - https://prerequisites.dappnode.io | sudo bash as shown in the guide to set up the pre-requisites.

This was the official dappnode iso release 0.2.39 i got from

The installer command completed with errors

wget -qO - https://installer.dappnode.io | sudo UPDATE=true bash

I am now able to reset my dappnode wifi password and vpn in over the internet. Dappmanager is updated to 0.37 and is now slowly getting packages from ipfs.

I still can’t ping my dappnodedns address so i am lacking NAT LOOPBACK.

I think I can install prysim once the package arrives but I worry that my dappnode is not healthy.

Thanks @ruvenni the wget command to get the dappnode force install worked!

I didn’t need to get the prerequisites.

I also had to fix my local ip address on my subnet and then do port forwarding to that address, port triggering to open the firewall on the router was not enough on its own.

A post was split to a new topic: natRenewal - Ports not opened

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.