CONTAINERS NOT RUNNING: debian | docker less than 20.10.2

The new Debian realese ( conflicts with docker version less than 20.10.2.

To check versions you can ssh into your dappnode and execute the commands:

  • Docker: docker -v
  • Debian: uname -a


if you are experimenting issues with containers not running and your debian and docker versions conflicts, as mentioned above there are two possible solutions.


  1. Reinstall dappnode (debian and docker will be up to date) with the new ISO available here

  2. Execute a script (available here) to update docker version (only advanced users): if you just want to update docker because debian is already installed, and have some tecnical knowledge you can follow the instructions defined bellow:

    1. copy the script (CTRL+C )
    2. go to your dappnode and use nano to create a new file like: nano
    3. Paste(CTRL+V) the script inside
    4. Exit and save the script (CTRL + X)
    5. Make the script executable using: chmod +x
    6. Execute the script: ./

Now docker should be updated to the latest version and should not conflict with debian


Thank you for posting this. I re-installed a couple times over the last days and went a bit crazy thinking it was port configurations on my lan as it has a bit of a different setup and no upnp. I re-installed with the new ISO and it worked beautifully. I was getting the error “Container {hash} not running.” This worked - thanks again!

1 Like