Container not running (SOLVED)

SOLUTION: Docker needs to be upgraded manually to latest version (Docker version 20.10.2, build 2291f61 as of now). Thanks to “pablomendez_95” on Discord for helping me out.

Original post:

After updating my system (NUC running DappNode) to the following: Linux dappnode 5.10.0-1-amd64 #1 SMP Debian 5.10.4-1 (2020-12-31) x86_64

I get the response: “Error response from daemon: Container XXXXXXXX is not running”

I can access the NUC via SSH, but it seems everything is at halt and my ETH is validator is stopped.

EDIT: Am getting help on the Discord. Will post the solution here if fixed. It appears to be the Docker version messing with me.


I ran into this problem today, too. I did a reinstall because I wasn’t able to log into my node. Coincidentally it was the same day I installed a new router and wifi setup, so I didn’t realize other people were having problems too…

Anyway, there is a big discussion about it in the Discord. You can see it here, along with a link to the new DAppNode ISO image they released to fix it.

There is also a post about it here in the forum:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.