Upnp issue although router UPnP is enable

Hello, I have the following message:
UPnP is enable on my router. I’m not sure what’s the next thing to check?

"Ports have to be opened and there is no UPnP device available

If you are capable of opening ports manually, please ignore this error
Your router may have UPnP but it is not turned on yet. Please research if your specific router has UPnP and turn it on"

Core DAppNode Packages versions

  • dappmanager.dnp.dappnode.eth: 0.2.36, branch: v0.2.36, commit: ad68eecb
  • core.dnp.dappnode.eth: 0.2.40
  • vpn.dnp.dappnode.eth: 0.2.7, commit: 12ae223f
  • wifi.dnp.dappnode.eth: 0.2.4
  • ipfs.dnp.dappnode.eth: 0.2.11
  • bind.dnp.dappnode.eth: 0.2.6

System info

  • docker version: Docker version 18.09.8-ce, build 0dd43dd87fd530113bf44c9bba9ad8b20ce4637f
  • docker compose version: docker-compose version 1.25.5, build unknown
  • platform: linux, x64, 5.9.0-3-amd64
  • Disk usage: 339731913114

Hi @yoyop

Networking and ISPs are hard to deal with sometimes but let’s try something: try to find an option in your router to set always the same internal IP to the dappnode machine.

Doing that solved it in my case, it seems like my router does not really applies UPNP if I don’t set a fixed internal ip, no matter how many times I enable UPNP o reset the router.

I hope this helps!

thanks for your answer. The error cleared by itself I haven’t done anything special.
I followed your advice anyway and went throught my router settings to make sure everything is set up correctly

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.