Update IPFS version issue

Hello, first off, I love this OS! Big thank you to all involved. I am having an issue updating the IPFS package.

I cannot use my DappNode while IPFS is on because it starts hogging all of my bandwidth and makes my network unusable after ~5 minutes. I’ve been running my Dapps with IPFS off (and auto updates off) and everything works great but this is obviously unsustainable. I read that the 0.2.13 version of IPFS has a fix to toggle low power mode and reduces bandwidth usage. I am currently running 0.2.12 (v0.7.0 upstream). I’ve tried…

  • Toggling the auto updates for the system (with IPFS on) in the DappNode GUI
  • Running my.dappnode/#/install/ipfs.dnp.dappnode.eth (which just redirects me to the admin page)
  • Running my.dappnode/#/system/update (it says System Up to Date)
  • Reinstalling the core packages using sudo wget -O - https://installer.dappnode.io | sudo UPDATE=true bash - After install, I’m still on 0.2.12 (I don’t think the IPFS package downloaded, the IPFS line said 857 --.- KB/S in 0s, but after it said Recreating DAppNodeCore-ipfs.dnp.dappnode.eth... done.
  • I also tried to achieve lowpower mode in IPFS via the JSON config in the IPFS Settings GUI by messing with the ConMgr object’s HighWater, LowWater and GracePeriod values. That didn’t affect the bandwidth takeover.

Any ideas how to force the IPFS package to update? Or any other ideas on how to stop IPFS from taking over my bandwidth so I can turn on auto update? Thanks!

1 Like

Hey! thank you for your feedback!! :smile:

Seems like you get it almost. To get you ipfs package up to date try to go to the dappstore and type:

If you prefer you could also type: “my.dappnode/#/installer/ipfs.dnp.dappnode.eth” (You was misspeling the word installer for install, so the dyndns server did not know where to redirect that domain and redirected you to the dashboard).

Now you should be able to reach the ipfs package update.

Typo! Thank you for your sharp eyes. It worked. Cheers.

same issue here, ipfs 0.2.12 seems buggy (using too much bandwith, update don’t work)

after a couple of tried on my.dappnode/#/installer/ipfs.dnp.dappnode.eth I managed to do the update.
I choose low power profile, accept admin privileges in dappnode api.
Is it ok to accept admin privileges in dappnode api?


@yoyop Yes! try giving the IPFS package admin privileges in dappnode api.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.