Unable to open the link provided in dappnode_admin

info:
ips 0.2.11
dappmanager: 0.2.35
vpn:0.2.7
core: 0.2.39
wifi:0.2.4
bind:0.2.6

Summary of the situation:

  • I can connect to the DappNodeWiFi
  • When I’m connected to the WiFi of the DappNode I’m not connected to the internet
  • I tried to open the link provided in the dappnode_admin, from all devices using my home network or the DappNodeWiFi and it cannot connect
  • Therefore I cannot download the configuration file for the VPN
  • I can restart the machine from the UI and I did so, but no change
  • I run the diagnostic and all is green
  • The router does not see the dapp node, which means that I don’t know the IP that it got assigned, unfortunately
  • If I look at the log there are few errors in the fetchCoreUpdateData last being the 15th, might be irrelevant

I made some additional reading. Might it be the NAT loopback?

At this link https://dappnode.github.io/DAppNodeDocs/troubleshooting/ it suggests to “edit the server address in the VPN profile and substitute the domain given by the internal IP of the DAppNode server (usually starting with 192.168………)”

The problem is that I don’t know the internal IP of the DappNode, that is because the router is not showing it in the list of connected devices. I tried also to ping on linux all the ip that the router recognized and they are there but no other internal ip give positive response.

Hi @ruvenni,

I found also this

and tried it but the part of the string is now different probably because the post is very old. Which part of the new string should I replace now? Moreover with which ip since the router does not list the dappnode among the connected devices?

Moreover it says " if the problem is about nat loopback you will have to edit the files so you can connect using them from the same lan as yor dappnnode is …to do so just open the file in a text editor , and substitute at the beginning after “remote” the dyndns domain with the internal ip again. You should use that profile to connect from your local network, from outside you can just the file as it gets downloaded."

What file it is talking about here?

An additional question could be… should I be connected to the DappNodeWiFi when I try do download the ovpn file or to the home network?

Once I get the ovpn file will I be able to use it on my linux desktop to connect from cable?

Hi @aldaril79

When you are connected to the DAppNode Wifi you should be able to browse normally as long as the DAppNode is properly connected to the router through an Ethernet Cable.

You can try with your smartphone or tablet using your data plan instead of the wifi. Also, try to set up new VPN connections. One for each device:

Here is how to find your ip address

@ruvenni, now I’m not at home, I’ll check this evening. However one thing I’m sure.

The dappNode is properly connected via Ethernet cable to the router. The DappNodeWiFi is visible, but when I’m connected to it I’m not connected to internet. This is a fact, I’ve also restarted the DappNode and the router and the problem stays.

I’ve already tried with my smartphone and it is always connected to data. Shall I disconnect from DappWiFi at the same time?

The only thing new that I can really do is this.

And if I’m able to see my ip I should also be able to ping it from linux, that’s what I’ll try, I’ll let you know.

Anyway man, thank you very much. It is very appreciated!

@ruvenni, I found the ip and I can ping it from my linux machine. I used my smartphone connected to DappNodeWiFi, data, my WiFi network to get the link and the answer is always the same “I cannot connect to the page”. I created different VPN connections each for each device and the answer is always the same. I can connect to my home WiFi I can connect via cable and the ip of the dappnode can be pinged. If I cannot create the ovpn file I cannot generate VPN connections.

To give additional information the dappnode ip is a very weird one it is very different from those which are automatically assigned by the router. However most probably you know already this

@ruvenni, Today I tried to ping the dappnode from the router and it does not find it, while if I ping it from the linux machine it sees it. Very weird.

I read other posts but they don’t really apply to my case, or I’m not really sure.

UPnP is on. Shall I set up port forwarding? Would I then need to set the static IP of the Dapp node to that given IP.
I have the impression that this should be something quite standard for you to solve…

@ruvenni, I would like to summarize my situation to make as efficient as possible your intervention.

I’m using the dappnode extreme, which I got a couple of weeks ago.
1 - When I initially connected to the router and switched on, the DappNodeWiFi was working and connecting to the network.
2- At that point I did not create a VPN connection and used the DappNodeWiFi. I did not know that was the first thing to do, unfortunately.
3- I started downloading Geth and the home network became totally unstable.
4- I tried to restart the DappNode from the UI, it did not restart.
5- I had to disconnect the DappNode to recover my home network.
6- After few trials and few nights, it seemed that the dappNode completed the download of Geth and the problems with the home network stopped.
7- However with the resolution of the network problem, also the DappNode WiFi stopped to be able to connect to the internet.

Current situation.
1- I can control the dappnode via WiFi but the DappNodeWiFi does not connect to the internet.
2- Home network works
3- Whenever I try to retrieve the ovpn file via the UI. The message is “cannot connect to the page”. The message is always there, weather I’m connected to the DappNodeWiFi, to my home network or to mobile data.
4- I can ping the ip of the DappNode from the linux workstation but I cannot ping it from the router. Thing which is totally mindblowing since they are both connected via cable to the router and the linux workstation is only connected via cable.
5- The IP of the DappNode is very different from those automatically set by the router.
6- The dappNode is all green and it was able to download Geth

I can provide the full log if necessary.
I have full access to the router and (with help) I can set up anything on it.

Shall I remove Geth?

Shall I set a static IP in the UI of the dappNode and, if there is any problem with it, would I still be able to connect to the DappNodeWiFi to set it back?

I see I can set in the router a port forwarding, providing this info:

Local IP
Local start port
Local end port
External start port
External end port
Protocol

is this something which might be useful to use the static IP on the DappNode?

Have you got the file that you need yet? I had the same problem getting the file but I got it in the end. I think I tweaked port sharing or something. Then my DECT phone wouldn’t work.
Now I can’t link to DappNode Admin to start the site with the „link/file“. I have a Fritzbox 7590 a high end router. I’m still trying to sort it out.
I‘m currently trying to decrypt this help doc… I personally think it assumes too much knowledge for an average guy. I’m 56 and not a complete computer dunce. https://dappnode.github.io/DAppNodeDocs/troubleshooting/

What EXACTLY am I supposed to type into the terminal… to check NAT LOOPBACK? Never heard of it before.

An example would be appreciated.

It sucks that you can’t get up and running especially since you paid for an extreme spec version. I custom built and made a bootable USB. It looks as if I’ve got further than you.

I didn’t buy from DAppNode but I did contribute to their GitHub grant rounds. So I still feel as if I’m not leeching off them. I appreciate it’s not easy. Let’s work this out together.

A useful little program is Fing to look at your network and ping stuff. For SSH use Termius…

@Blackswan, no it did not. I’m a programmer of scientific code but I have no experience with internet, GUI or Blockchain. I really hope that @ruvenni will help us.

I saw your post and it is marked solved. Does your WiFiDappNode connects to the internet?

I read the link that you are mentioning many times. Yes I think it is unclear. I have the additional problem that I leave in a country of which I don’t speak the language so all the discussions on the router require a lot of work to be understood. I already spent a huge amount of my little free time to figure this thing out.

In any case for what I have understood many common internet providers do not allow NAT LOOPBACK for security reasons, I don’t know what that is though. It seems that they have an alternative for it (in the same link) but is not well explained.

BTW I bought a very expensive hardware from them and in two weeks I’ve receive two answers from @ruvenni which revealed to be ineffective. Of course all this thing is quite a reason of stress for me as for you (as I can read in between the lines). I guess there is very little we can do, except coming back here, hoping for a decent answer and continuing investigating. That’s why I try to ask clear questions to make that “my one answer per week” is as useful as possible.

If I think that one day I need to stake on this thing… Kind of scary thought.

Yet you have the luck that you have your own hardware. You can just delete dappNode and follow the instruction to set a ETH validator in the standard way.

My issue isn’t solved…I am getting slowly further I now have the file and it’s running in OpenVPN…but that’s it…I don’t know what it’s then supposed to do… it says" initialisation completed successfully" I’ve configured my ports to be open TCP 8092 and UDP 1194 (in install doc it says TCP 8090 not 8092…so i’ve opened both until I get an answer)

I have a connection as its saying bytes in and out…but more i don’t know…

Where did you get these from?

@Blackswan Those are from the UI. Unfortunately I’m at work so I cannot take a screenshot

@Blackswan go here.