Stuck on loading VPN parameters - NUC 8

OK, I think I have a different cause to: Stuck on loading vpn parameters

I’m using a NUC 8. Which I’m assuming is currently supported.

Installing from ISO.

dappnode_connect gets stuck at loading the VPN parameters.

Ping results in “Temporary failure in name resolution”

I’ve managed to connect my laptop to the DappNodeWIFI (and have changed the password).Then I can connect to my.dappnode directly. If I check the support page, I get the following:


I suspect that the problem is between the NUC and my broadband connection (Virginmedia hub) UPnP is enabled. When I log onto the Hub @ I don’t see the NUC / Dappnode listed as a connected device via wifi or ethenet cable. When I plug a working ethernet cable into the hub and NUC I don’t see any lights…

My intention is to locate the NUC next to the HUB and use a direct ethernet cable to connect them. But first I need the VPN working.


I’ve tried a couple more things.

Flashing the NUC bio to the current version (0081) had no effect.

If I boot the NUC using a USB drive with Ubuntu 20.04 I have what appears to be a working ethernet port.

I may try installing ubuntu on the NUC then installing DappNode on top of that…


Progress. I installed ubuntu uisng a USB stick (then followed the install instructions from here:

Wifi and ethernet working, VPN working (using a direct address). so my.dappnode now works.

In all about 1 hour to get up and running.

Now I have to sync everything…


Hey @overanalyser, how did the syncing go? Are you up and running?

I got Geth and GroeliGETH running no problem.

For Medalla genesis i started a lighthouse client on the ubuntu and thats been running fine.

I tried the Dappnode Medalla client a week ago and prysm beacon didn;'t syn so, I restarted my lighthouse client outside Dappnode.

I’ve turned my lighthouse off today and tried to install and run the Dappnode Medalla client.
I had a time syncronisation problem for a while, but a couple of restarts seems to have fixed it.

Prysm Medalla beacon chain has 35 peers but the epoch appears a couple behind

The Medalla validator dashboard shows: Current epoch: 8 (synched), 30 peers.

The Medalla log looks like it’s working on the correct slot, but I’m not seeing any attestations on

I’m hoping it just needs some more time to fully synchronize. I may try restarting the packages later.

OK, apparently some of my problems were due to the prysm / roughttime issue. I tried to switch to lighthouse package within dappnode, but it didin;t look like it wanted to sync.

So, I’ve restarted my lighthouse client within ubuntu.

I’ll try the dappnode medalla packages another day

I had the same issue as the first post.
I did a clean Ubuntu install and currently have GoerliGETH, Nethermind and Lighthouse running.
Nethermind has been running fine, but I did experience issues with syncing the others. Haven’t been able to troubleshoot yet

OK, I’ve just tried the current ISO as a clean build (.2.37 Debian-bullseye-amd65.iso on my NUC, and I’m getting the same problems with it not connecting to the wifi or a direct LAN cable (Everything is on in the NUC bios) .
It’s a new router that appears to be working, so I think the problem is still the ISO with the NUC hardware.

[NUC desktop Board NUC8BEB, Bios BECFL357.86A.0081.2020.0504.1834]

I’ve gone back to Unbuntu desktop + install on top of that as that gives me more flexibility


This is beyond my knowledge… @Edu, any thoughts?

1 Like

this is my experence as well - seems like there is no support for this bug yet. have not found a solution after 8 hours

Solved for NUC10


Dappnode must be flash installed with ethernet hardwire connection, not wifi

npv config file must be downloaded while connected to dappnode wifi


LAN connection for the install from ISO worked for me, VPN connected and appears to have solved my LAN issues.

1 Like