Rpc connection problem

If I go into sytem → network → https portal and expose to json rpc of geth or rinkeby I get a public url, but when I try to use that public url it doesn’t seem to work, can somebody tell me if I need to elaborate in some way that link? it is something like rinkeby.xxx.dyndns.dappnode.io or geth.xxx.dyndns.dappnode.io


I just notice that the issue might be because you are not using the prefix: https//. If you copy the link address you will notice that it comes with https://

Also, how do you verify it does not work? It may take some time to your dappnode to do the configuration necessary.

I suggest you to check it using one of the following methods:

  1. Open a terminal and execute the following command to check your RPC is working:
curl --location --request POST 'https://rinkeby.xxxx.dyndns.dappnode.io' --header 'Content-Type: application/json' --data-raw '{
  1. To avoid doing tecnical stuff, simply go to this website and set your RPC endpoint to do a test using any of the method available. An example screenshot:

Thank you for your response, yes I have tried both with https and http as prefix, but it still doesn’t work, I have a web3 project that I use to check if the rpc is good, and everytime I use the one given me by appnode it fails, so the rpc doesn’t work

1 Like

hi!, I have the same problem when I try to call geth.xxxxxxxx.dyndns.dappnode.io. In my case only work when call behind dappnode Wifi if I make request to http://geth.dappnode:8545

I test to ping dns of dappnode and is ok:
❯ ping geth.xxxxxx.dyndns.dappnode.io
PING geth.xxxxxxxx.dyndns.dappnode.io (5.xxx.xxx.82): 56 data bytes
64 bytes from 5.xxxx.xxxx.82: icmp_seq=0 ttl=64 time=8.308 ms
64 bytes from 5.xxxx.xxxx.82: icmp_seq=1 ttl=64 time=17.952 ms
64 bytes from 5.xxxx.xxxx.82: icmp_seq=2 ttl=64 time=7.685 ms

I need some extra configuration to connect to geth.xxxxxxx.dyndns.dappnode.io from other machine?


I am having the same issue.

The response from the curl command is:

curl: (7) Failed to connect to geth.xxxxx.dyndns.dappnode.io port 443: Connection refused

The response from the open-rpc playground is:

  "jsonrpc": "2.0",
  "id": 0,
  "error": {
    "message": "Failed to fetch"

As sergiocontre wrote, I am able to successfully ping the dyndns address, so I know it’s there.

Any help would be greatly appreciated!

More research:
The port 8545 doesn’t even seem to be open to the geth container. I ssh into the dappnode, run docker port DAppNodePackage-geth.dnp.dappnode.eth and get back:

30304/udp ->
30304/udp -> :::49153
30303/tcp ->
30303/tcp -> :::49153
30303/udp ->
30303/udp -> :::49154

The docker ps PORTS sections shows:
8545-8546/tcp,>30303/tcp,>30303/udp, :::49153->30303/tcp, :::49154->30303/udp,>30304/udp, :::49153->30304/udp

Where all the other mappings that show up in the docker port command show a -> to show that a mapping was set up, there is none for 8545/8546/tcp