OpenVPN: WARNING: Your certificate has expired!

I recently started getting the above error when trying to connect to my dappnode via openvpn. I accessed the server by IP addess, ie: , and downloaded the .ovpn file, but still got the same error.

I am assuming I need to regenerate something?

1 Like

Has anybody got any suggestions here?

I’m also seeing this and would like to know how to renew the certificate

Knowing that I am not the only person experiencing this is very comforting!

Looks like a couple people are asking the same question on Discord. I’ll post the responses here if anything useful happens

I got it!

ssh into your dappnode server, and switch to the root user.

cd /usr/src/dappnode/DNCORE/
docker-compose -f docker-compose-vpn.yml down -v
docker-compose -f docker-compose-vpn.yml up -d

Make sure you use the -v option on the down command. This removes the old volumes, where the Certificate was stored. The -d option on the up command starts the container detached, so that it doesn’t shut down when you log out.

1 Like

Thank you! This worked for me.

in my case I don’t have the file “docker-compose-vpn.yml” inside the DNCORE directory… any idea what I should do?

What files do exist in that directory?

I ended up completely re-install everything on my dappnode, so my error is gone now. Thanks for offering to help Mark!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.