NUC DappNode Mini Wifi suddenly not connecting

my NUC runs since 14 days stable. but I have the wifi problem. suddenly I can not connect anymore. if I coldstart my NUC it works again. i did this several times in the last 2 weeks but don’t think its the way to do it.

Screenshot 2020-12-21 at 17.04.26

my nuc is from dappnode directly.

Before filing a new issue, please provide the following information.

Core DAppNode Packages versions

  • 0.2.37, commit: 2b96e582
  • 0.2.41
  • 0.2.5
  • 0.2.12
  • 0.2.7, commit: 12ae223f
  • 0.2.6

System info

  • docker version: Docker version 18.09.8-ce, build 0dd43dd87fd530113bf44c9bba9ad8b20ce4637f
  • docker compose version: docker-compose version 1.25.5, build unknown
  • platform: linux, x64, 5.9.0-1-amd64
  • Disk usage: 353690556826

Hi @spkeaboo and welcome to our community forum!!

Thanks for sending all the core packages information!! We also need to know what packages from the DAppStore are your running - find them at http://my.dappnode/#/packages

Hi @ruvenni

I run prysm & Geth. eth2 stakingScreenshot 2021-01-02 at 14.59.14

it seems my system was not running properly in the last 10 days. I was not at home. It says now in prysm the quality is poor and I got slashed and lost some eth.

i cold started the system to connect again. it was not possible to connect via WIFI.

after 10 minutes or so the connection is lost and the NUC is running out of memory or something

auto diagnosis looks like this. IPFS is not resolving, not more happening. can not connect again to prysm.

losing money, each epoch.

Screenshot 2021-01-02 at 21.06.18

What can I do to stop it ? I can not restart my NUC/Dappnode all 10 minutes.

Screenshot 2021-01-02 at 21.06.23

i tried an tested everyhting back and fort.

password wifi for sure correctly chanced and working fine after each cold start.

then the system tries to sync GETH again but then after 10 mins “runs out of memory”. memory usage goes to 94% and syncing of GETH stops (logs confirm that) and can not connect again to wifi all stops. when I restart, the same thing starts again.

i restarted GETH. same thing again. my NUC Mini comes from you dappnode, is it installed with to less Memory ? internet connection is very good.

Screenshot 2021-01-03 at 15.01.35

kind of fixed it now with pausing prysm, let geth sync and restart geth, unpause prysm.

it voted now correct for 1-2 epoch and I hope it comes through the night.

I think the main problem is, that 8 GB RAM is not enough? why do you sell a NUC mini with just 8 GB for ETH staking?

can I upgrade the RAM myself? do I have to pay attention to anything?


Hi there @spkeaboo

I think it’s caused because there is not enough RAM. I’ve had the same problem.
I’ve tried to have geth, openethereum and prysm synched but it failed.
Now I only have openethereum and prysm.
You can configure a remote Eth1 node for Prysm. I’m usign infura.

I tried to upgrade the RAM for the small dappnode in this thread.

@spkeaboo So sorry for the response delay!

There have been reported some issues related with the staking process and the mini dappnodes, it seems like the staking process consumes a lot of RAM, this may cause other services to crash.

Anyway dappnode team has worked hard to solve this issue and there has been created some features you could try to solve the problem you are experimenting, please check this post and try that solutions.

Let us know if it works!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.