No Longer Able to Connect to DAppNode

I’ve been running my DAppNode for about 2 months now (Bitcoin, GoETH, Geth, & Medalla Validators). I have been able to connect to it via OpenVPN and things have been running smoothly.

However mid last week, I noticed that I was unable to connect to the node anymore through OpenVPN. The node appears to still be running smoothly as I can see that the validators are still attesting. I just can’t VPN into the node anymore to access the admin UI.

I’m not sure why this is happening, as I can’t think of anything that has changed to my network / setup. I have tried re-booting the node and re-running dappnode_connect, but when I scan the resulting QR code, the URL does not load in any web browsers.

Seems like something has gone sour with the VPN connection out of the blue. Not sure what to do next… any suggestions?

Okay so I figured out the problem. Somewhere along the line, my DAppNode was restarted. And when it came back online, it was under a different internal IP address.

E.g., the old internal IP could have been something like:

And the new internal IP is something like:

This change required me to log into my router’s admin UI, go to the “Port Forwarding” section, and change the ports I had originally opened for DAppNode to use the new internal IP instead of the old one.

Problem solved!


I really appreciate you posting the continuation! Thanks!