Mini DAppNode not booting up

Completely baffled once I plugged in my new Mini DApp Node and I’m getting either a Debian login prompt (for which I have no clue what to put) or what looks like somtehing asking for Wifi settings (my guess) displaying:

iwlwifi 0000:00:0c.0: BIOS contains WGDS but no WRDS

I kinda tried typing my router wifi settings with no success.

What am I supposed to do? Thanks

Try typing ‘exit’ on the boot screen

I also got a new mini dappnode and i’m getting something similar just a debian login prompt. Not sure what to type in.

can you upload a screenshot or picture?

have you tried login as: dappnode/dappnode (default) or whatever user/pass specified during the

you should see the QR code and dappnode’s IP within your LAN.

Alternatively, can you see the DAppNodeWiFi hotspot? passphrase by default (I think is dappnode123)

once connected to the wifi you can visit http://my.dappnode/ to access dappnode dashboard.

Hi, thanks for the reply - no hotspot wifi detected even though it is plugged into the router and upon boot up it goes straight to login/password prompt. I tried u/p dappnode/dappnode but it only says incorrect login. I never installed anything since I was under the impression that it came pre-installed (mini dappnode). Sorry, not sure if this is the same problem that santisiri is also having but it sounded similar.

Hi, yes @adaptivex this is the same problem I’m getting. I wasn’t able to find any troubleshooting for this in the documentation, and it looks like could be a common thing. It’s a bit frustrating not being able to use the mini dappnode at all.

Here’s two pictures:

Help! :slight_smile:

i’ve never seen any installation process take off when I first boot the machine.

dappnode/dappnode is not allowing me to log into the device.

I do see the DappNodeWifi hotspot but won’t login with dappnode123

Hi santisiri, I have it working now. I had to startup my dappnode after logging in to the system. I was able to login using a specific username and password provided by the DappNode team. Since you can see the DappNodeWIFI, I wonder if you can login to it simply by using the password “dappnode”. My issue was that I could not see the wifi and had to startup the services. Once the DAppNodeWIFI was up for me i was able to connect and run the steps found at

Hi @adaptivex… where did you get that username and password exactly?

I can login to the wifi… but then I can’t do much else, since I’m not logged in the device I guess that’s why I can’t access my.dappnode/#/devices

Hi @santisiri

First of all, the message:
iwlwifi 0000:00:0c.0: BIOS contains WGDS but no WRDS
is just a kernel warning, but wireless should work anyway.

Second, to log in to your dappnode, the default credentials are:

user: dappnode
password: dappnode.s0

(last char is a zero)

If you are connected to the wifi, you should be able to access the ADMIN user interface directly from you browser, are you getting any error? What IP do you get when connected? Can you clean you cache and retry?

1 Like

Thanks @vdo! now I managed to move a step forward and I can finally log in.

I’m trying to download the OVPN config file that the QR code displays but no luck with that now. Activated UPnP on my router and opened 1194 UDP port but I think Mac OS X is still keeping these ports firewalled. I’m looking through a way to open these up… .

Also when connected to DappNodeWiFi, I try to go to the internal IP reported in the console login but i’m getting a connection timeout…

When connected to the WiFi, can you actually browse http://my.dappnode ??

Tried rebooting the device and connecting all over again and still gets stuck resolving host... even using an incognito window to avoid any cache issues…

Screen Shot 2020-06-16 at 3.13.47 PM

No luck also rebooting my machine… turning off the firewall… etc, etc… followed these steps to open UDP por 1194: … still no luck.

is there any alternative to get the OVPN file? What options do I have left?

  • Did you check if there’s a NAT Loopback enabled in you router?
  • Can you get the QR code if you try using LTE/mobile network, so you are not within the same network?
  • Another workaround would be to substitute the part of the URL with the local IP of your dappnode (something like 192.168.x.x)

Hi @vdo, I’m attaching my router settings here… it looks like NAP loopback is enabled:

(Also, let me know if the 1194 UDP settings are ok)

Screen Shot 2020-06-18 at 6.17.01 PM Screen Shot 2020-06-18 at 6.16.55 PM

QR code won’t work over the LTE/Mobile network.

I tried the local IP once I’m in the DappNodeWiFi but still getting a timeout.

The external start- end should be 1194 on both,and also 8090 TCP so you should enable:

Name Ext Start Ext End Protocol Int Start Int End
Whatever 1194 1194 UDP 1194 1194
Whatever 8090 8090 TCP 8090 8090

However, it is recommended to enable UPnP so ports are mapped automatically.

Also, check if your provider is not using double NAT, or cgNAT (so your router IP is actually exposed to the Internet)

The link with the local IP should be used outside of the DAppNode Wifi. I assume your node is connected via ethernet cable.