Ipfs stopped working after update to v.0.2.20

After update to v.0.2.20 Ipfs is constantly restarting.
DAppNode packages are not accesable.

The Ipfs log is as follows:

See fs-repo-migrations/run.md at master · ipfs/fs-repo-migrations · GitHub for details.
ipfs version 0.22.0
Found IPFS fs-repo at /data/ipfs
ipfs migration: already at version 15
Error: Your programs version (14) is lower than your repos (15).
Please update ipfs to a version that supports the existing repo, or run
a migration in reverse.

Help is very appreciated,
Thank you!

Before filing a new topic, please provide the following information.

Core DAppNode Packages versions

  • bind.dnp.dappnode.eth: 0.2.6
  • core.dnp.dappnode.eth: 0.2.77
  • dappmanager.dnp.dappnode.eth: 0.2.72, commit: 26bbe6f9
  • https.dnp.dappnode.eth: 0.2.1
  • ipfs.dnp.dappnode.eth: 0.2.20
  • wifi.dnp.dappnode.eth: 0.2.8
  • wireguard.dnp.dappnode.eth: 0.1.2

System info

  • dockerComposeVersion: 1.29.2
  • dockerServerVersion: 20.10.24+dfsg1
  • dockerCliVersion: 20.10.24+dfsg1
  • os: debian
  • versionCodename: bookworm
  • architecture: amd64
  • kernel: 6.1.0-9-amd64
  • Disk usage: 22%

Resolved by:

  1. Switch from local to remote at http://my.dappnode/repository/ipfs

  2. Update to v.0.2.21 at http://my.dappnode/installer/dnp/ipfs.dnp.dappnode.eth

  3. Switch back to local at http://my.dappnode/repository/ipfs

Credit to: Discord


Thanks @apronozin !
Fixed pushed!

you are a gentleman and a scholar.

Well you solution fixed it for me!

But, man! I feel like I tried every variation on this before finding your solution, and nothing seemed to work.

Maybe it’s because I didn’t specifically tell my dappnode the target URL from step 2.

But thanks for sharing!

I am relatively new to all this stuff myself. Being able to help gives me a good feeling. Thank you for your review. And by the way, honestly, it’s not my solution; I took it from DAppNode’s Discord.

tyvm @apronozin for posting here as well :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.