Intel Nuc 12th Gen "No Ethernet Card" error - ISO support

I am trying to install from the ISO on a new Intel Nuc i7 12th Gen and am getting the error: “No Ethernet card was detected.” I’m assuming based on previous posts a couple years ago about the Intel Nuc 10th gen that this is because there isn’t support for the 12th gen in the ISO yet. Am I correct?

Does anyone know when the ISO will include support for the Intel Nuc 12? Or am I stuck installing the latest Ubuntu OS and then installing DAppNode via the script method?

4 Likes

I just fired up my brand new Nuc i7 12 Pro and ran into the same issue when trying to install DAppNode.

What’s the best path forward? Wait for a new ISO? Or something else??

I just checked Github and it looks like this is in action already. A pull request is pending approval.

We have been testing a new ISO just for the NUC12s the last week or 2 now, we will have a release just for the NUC12 models soon since it requires several extra firmware files and a newer version of Debian, especially for the top end model. It works I’ve been testing it with the core devs and it should be available for everyone soon once it’s fully tested and has no errors and installs all needed drivers. I will give an update here when it’s ready!

You guys can contact me @voss by DM here on the forum, or preferably on our Discord server if you haven’t spoken with the Devs already. May be able to get an early version out to people having issues with brand new machines trying to install and have no network. By the way, I did find certain driverless USB-Ethernet Adapters that work seamlessly in the meantime, but most do not. Shockingly the best one I found was a USB-3 A(Standard Male Rectangular Plug) to 5Gbps Ethernet and it auto-scales so it can do 1, 2.5, and 5 Gbps. depending on the speed of the switch or router it’s connected to. I tried 10 models and all were supposed to be driverless and/or work with any kernel over 3.2, but only 1 worked, even the one I use on my NUC8 for faster network uplink at 2.5Gbps didn’t work and it was plug n play driverless with USB-C on a much older NUC.

1 Like

Hi guys! I have been testing different options for the NUC 12. The branch is not merged yet because we are still trying to find other solutions. However, you should be able to install DAppNode from “diego/fix-nuc-12-iso” or from “development” (if you want to have also the new way of installing docker)

To get the ISO, you have to:

  1. Clone the repo
  2. Checkout to the desired branch
  3. Edit docker-compose.yml and set unattended to ‘true’(OPTIONAL)
  4. Execute $docker-compose up (and check it returns 0 → if not, repeat this step)
  5. The ISO can be found in /images directory
1 Like

Btw, it would be extremely helpful if you give us feedback when you try the ISO for the NUC 12. You can contact me via our discord server (@dsdiegosg) and if you have any more issues when can try to fix them together!

1 Like

Great news! Thanks for the update. I can test this weekend. I’ll report back afterwards.

1 Like

Hi @dsdiegosg, I was able to build the image from your branch and install it without apparent issues. WIFI works fine, since I can connect to the dappnode wifi hotspot and LAN must also work fine, since my router sees my dappnode machine without problems and the dappnode machine got an IP assigned via DHCP.

Now the only issue I am facing, and I don’t know if it is related to this image, is that I can only connect via WIFI to the dappnode admin interface. But If I try to connect to the dappnode.local, it cannot be found (obviously I am on the same network 192.168.0.*). Any hints for me? Do you think it may be related to that special image? or something else going on?

pinging dappnode.local gives me a working ping on an ipv6 address. Connecting to it via the browser is however not working.

1 Like

I am not sure if this has to do with the new image. I would say it does not… We have the dappnode.local way of accessing the dappnode just as an alternative, but we recommend to use the other methods we provide to access the dappnode, as dappnode.local does not allow to go to multilabel domains, i.e., you won’t be able to go to package UIs, for example.

Hi Diego, thanks for the info. I assume it’s not related then. I won’t be looking more into it and go with the primary methods of access (Wifi / VPN).

Would you recommend waiting for a stable release for nuc12? Or do you think we go ahead with configuring and using the DEV version? Can we simply update the dappnode later on without losing our configuration?

Thanks for you help. I am amazed at the effort you guys put into this.

The problem is that right now, the stable branch of Debian does not include the firmware that is needed for the wifi card and Debian 12 won’t probably be launched until February next year… At the moment we will try to stick to the NUC 11s, as the way of fixing this wifi issues is installing firmware from backports…

I have no idea about when are we expecting to have this firmware in the stable branch…