Installation issues (both ISO and script)

I’ve run into multiple issues trying to get dappnode installed.

The first was running the preseed script near the end of the iso installation. It abends with the error “sh: getent: not found” (seen in the install log), almost like the “in-target” function is not working properly. I tried running this on various configurations and always received the same error.

I then installed a vanilla install of Debian 10 and ran the online bash script, and low and behold the first time it worked and I was able to scan the code, configure the VPN and everything was golden. Unfortunately, I needed to upgrade the system with ssds (rather than the iscsi share I used initially) to better sync the eth blockchain and have not been able to run those scripts since. I’m not sure if they were changed online, but even trying to reinstall under circumstances identical to before, it fails. The last message I see is “Downloading BIND tar…” which is not in a green font, and then it just kicks me back to the prompt.

I’ve since installed debian and openethereum, and I’ve managed to sync to the blockchain, but I’d like to get dappnode installed and I really did like what I saw during the brief period that I was using it. Any help/insights would be appreciated.


Did you uninstall DAppNode with the script?:
wget -qO - | sudo bash
And reinstall it with:
sudo wget -O - | sudo UPDATE=true bash

Reminder to have the prerequisites installed with:
sudo wget -O - | sudo bash

If you have some problem, could you past what do you see when the installation process fails ?

Yes, I’ve tried both the uninstall script as well as installing on a fresh installation of debian. And yes, I install the prerequisites first, and that completes fine. During the install script, no errors are given, the script just stops after “Downloading Bind tar”. See image.


No error, the script just ends without installing dappnode.

Hi there! I will try to reproduce your error and try to debug whats going on.
Within the next 48 hours will post here an answe well detailed :slightly_smiling_face:

ok great! thanks so much for your help!

OK, I started looking at the scripts and found the problem… evidently the url for the .dappnode_profile config file changed. the bash script tries to pull it from:


when it is now located at:


I downloaded the script locally and modified it and it runs fine now. :smiley:

1 Like

You are right!!

The reason is that we are doing a refactor of the installer and we have no published yet the new release. I Will do a hotfix for this issue

Thank you!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.