How do I re-generate prysm Web-UI auth token?

Prysm docs is telling me to do validator web generate-auth-token.

Here is what I’ve tried:

root@dappnode:/# docker exec -it c5e6fcd69f4a /bin/bash
root@c5e6fcd69f4a:/# validator --prater web generate-auth-token

WARN flags: Running on the Prater Testnet
INFO rpc: Generating auth token and saving it to /root/.eth2validators/prysm-wallet-v2/auth-token
FATAL web: Could not create web auth token: open /root/.eth2validators/prysm-wallet-v2/auth-token: no such file or directory

I then created dir prysm-wallet-v2 and file auth-token and run validator command again and got this:

INFO rpc: Generating auth token and saving it to /root/.eth2validators/prysm-wallet-v2/auth-token
INFO rpc: Once your validator process is runinng, navigate to the link below to authenticate with the Prysm web interface
INFO rpc:

Web-ui still doesn’t recognize this token though.

1 Like

im having the same problem

It’s been 19 days, I still don’t have a clue how to do that.
So should I nuke my dappnode and start from scratch?

Hey i was just informed of this, I’m part of the Prysm team. you can find information around this here Using the Prysm Web Interface | Prysm with dappnode you should just able able to click on the url and it should open it… on discord and you can go to the prysm channel to report more about your specific issue.

in terms of your error, you are trying to run prysm on dappnode’s setup. i guess dappnode overrides the wallet location please see here
now you don’t have to fully understand the code but you’ll see both the command for token regeneration as well as starting the validator in there. you can see that they specified a different location for the token.
but restarting the docker file should regenerate this, take a look.
let me know if you have questions.

1 Like

also i see that there is an ip address used, please follow instructions from here How to Access The Prysm Prater WebUI in v0.1.5 (Upstream v2.0.3) and Above

1 Like