Geth Light Client will not sync

Due to drive space issues I switched from a full Geth node to using the light client. I completely removed the Geth volume and uninstalled the Geth package before reinstalling and selecting the light client. After install it starts up and hangs at this point in the logs:

INFO [01-19|00:44:51.183] Starting Geth on Ethereum mainnet... 
INFO [01-19|00:44:51.183] Dropping default light client cache      provided=1024 updated=128
INFO [01-19|00:44:51.184] Maximum peer count                       ETH=0 LES=10 total=50
WARN [01-19|00:44:51.184] The flag --rpcapi is deprecated and will be removed in the future, please use --http.api 
INFO [01-19|00:44:51.184] Smartcard socket not found, disabling    err="stat /run/pcscd/pcscd.comm: no such file or directory"
INFO [01-19|00:44:51.184] Set global gas cap                       cap=25000000
INFO [01-19|00:44:51.184] Allocated cache and file handles         database=/root/.ethereum/geth/lightchaindata cache=64.00MiB handles=524288
INFO [01-19|00:44:51.195] Allocated cache and file handles         database=/root/.ethereum/geth/lespay         cache=16.00MiB handles=16
INFO [01-19|00:44:51.205] Writing default main-net genesis block 
INFO [01-19|00:44:51.386] Persisted trie from memory database      nodes=12356 size=1.78MiB time=44.3596ms gcnodes=0 gcsize=0.00B gctime=0s livenodes=1 livesize=0.00B
INFO [01-19|00:44:51.386] Initialised chain configuration          config="{ChainID: 1 Homestead: 1150000 DAO: 1920000 DAOSupport: true EIP150: 2463000 EIP155: 2675000 EIP158: 2675000 Byzantium: 4370000 Constantinople: 7280000 Petersburg: 7280000 Istanbul: 9069000, Muir Glacier: 9200000, YOLO v2: <nil>, Engine: ethash}"
INFO [01-19|00:44:51.386] Disk storage enabled for ethash caches   dir=/root/.ethereum/geth/ethash count=3
INFO [01-19|00:44:51.386] Disk storage enabled for ethash DAGs     dir=/root/.ethash               count=2
INFO [01-19|00:44:51.387] Added trusted checkpoint                 block=11042815 hash="d42b78…6c716b"
INFO [01-19|00:44:51.387] Loaded most recent local header          number=0 hash="d4e567…cb8fa3" td=17179869184 age=51y9mo2w
INFO [01-19|00:44:51.388] Configured checkpoint registrar          address=0x9a9070028361F7AAbeB3f2F2Dc07F82C4a98A02a signers=5 threshold=2
INFO [01-19|00:44:51.388] Starting peer-to-peer node               instance=Geth/v1.9.24-stable-cc05b050/linux-amd64/go1.15.5
INFO [01-19|00:44:51.404] UDP listener up                          net=enode://021dd813db9bb8ed5594ee7d6f0bc5d6e027c8e5b13feba78f597476e74643858fdde9b26053e98343b356e65fd3a0af2075c1fbe96dc33c5b4ad092b8084a6d@[::]:30303
INFO [01-19|00:44:51.407] New local node record                    seq=1 id=87228c51a1d9490c ip= udp=30303 tcp=30303
INFO [01-19|00:44:51.407] Started P2P networking                   self=enode://021dd813db9bb8ed5594ee7d6f0bc5d6e027c8e5b13feba78f597476e74643858fdde9b26053e98343b356e65fd3a0af2075c1fbe96dc33c5b4ad092b8084a6d@
INFO [01-19|00:44:51.407] IPC endpoint opened                      url=/root/.ethereum/geth.ipc
INFO [01-19|00:44:51.407] HTTP server started                      endpoint=[::]:8545 cors=* vhosts=*
INFO [01-19|00:44:51.407] WebSocket enabled                        url=ws://[::]:8546
WARN [01-19|00:44:51.407] Light client mode is an experimental feature 

I saw another post titled “Light client : Syncing” that mentioned using an earlier version of the Geth package worked. I’m using Version: 0.1.12 (v1.9.24 upstream). The package manager UI doesn’t seem to give the option to install a different version. How do I fix this?

We don’t see any problem in your logs, we think It’s possible your node doesn’t synchronize because there are no slots available.
I mean, Geth Light Client requires to connect to a slot. These slots are provided by Geth Full Node Clients. If your node doesn’t find a free slot it will not connect to and synchronize.

You can report this issue to Geth. You have to submit an issue to their repository Issues · ethereum/go-ethereum · GitHub inform about this situation.

Interesting. It seems strange that it would not find a full node that will serve a light client. It’s been running in light mode for about 3 days now and has not connected or changed state the entire time.

I had the same problem. Bear in mind light clients are an experimental feature from the Geth team and it might be broken at the moment…

EDIT: reviewing the changelog of the latest geth version (upstream v1.9.25) I see that it includes a fix for light clients having difficulties finding peers.

I have opened an issue in the repo: Geth in light client mode does not find peers - update to Upstream v1.9.25 · Issue #256 · dappnode/DAppNode · GitHub

Thanks reproducing and for opening this as an issue. I will definitely try using the light client again once the upstream version gets bumped on the DAppNode Geth package.

DerpDiggler, try with the new last version of geth(0.1.13 (v1.9.25 upstream)) I have updated and I could synchronized geth in a light client so fast(less 1 hour).
One of the bugs this release solves is “Light client peer discovery now uses DNS”. I think it was the error we had.

1 Like

Right on! Just updated and my Geth light client is syncing now. Thanks for the help getting this issue resolved.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.