Exit Validator [Command Line] - Prymont?

After a few weeks of validating on the Prymont network, I’d like to learn how to complete a successful exit. Of course I could simply delete the Prymont package and Goeril Geth, but I know that’s not ideal for the test net health. I searched around the Discord channel and came across someone that completed an exit via the command line. The command they used was:

validator accounts voluntary-exit --prymont --wallet-dir=/root/.eth2validators --wallet-password-file=/root/.eth2validators/walletpassword.txt --beacon-rpc-provider beacon-chain.prysm-prymont.dappnode:4000

Linux command line is not exactly my strength.
Currently at the terminal dappnode@dappnode:~$. when I type in the above command I receive an error that the validator command is not recognized. Perhaps I have to go into another directory before? Or maybe change my user?

1 Like

I’m trying to get my head around this too but this should get you started:
On a dappnode Prysm is running inside a docker container

First you need to get into the container

I used this method

dappnode@dappnode:~$ su -

Password: your root password

dappnode@dappnode:~# docker -v [ this is just to check that docker is running]

Docker version 19.03.8, build afacb8b7f0

dappnode@dappnode:~# docker exec -t -i DAppNodePackage-validator.prysm.dnp.dappnode.eth /bin/bash

From there

Cd /root/.eth2validators should get you to where you can execute the exit


Thanks for the help! The docker containers are great, but they sure can make life difficult. Encountered another error and decided it would be best for me to stop playing around on the command line. Transferred my prymont validator keys to a second computer and exited without any problems.

1 Like

I also wanted to complete a successful exit of the testnet instead of just deleting the packages and thanks to you guys and discord I was able to. Just wanted to share a few corrections in case it helps anyone. @Essohara was correct in needing to go into the container:

but a -pyrmont was left off of the container name for me. In full the command was:

docker exec -it DAppNodePackage-validator.prysm-pyrmont.dnp.dappnode.eth /bin/bash

or whatever comes up as the container name from the command “docker ps”. Also, for what it’s worth I didn’t make a root user so I did not need to use su-.

Then from the .eth2validators directory the command @enashton posted is correct but pyrmont is spelled prymont twice. After I corrected that it worked:

validator accounts voluntary-exit –pyrmont --wallet-dir=/root/.eth2validators --wallet-password-file=/root/.eth2validators/walletpassword.txt --beacon-rpc-provider beacon-chain.prysm-pyrmont.dappnode:4000

Then you just follow the directions. Hope this helps someone. Thanks again, see yall on the mainnet.

1 Like

Is the only downside of simply deleting the pyrmont and Goerli Geth packages is that it affects the testnet health? Will doing this cause any issues when staking on mainnet?

I’d like to exit the testnet properly but also don’t want to play around with it too much in case I mess something up

Hi there – I’ve tried exiting with the above instructions, but get an error:

unrecognized argument: beacon-chain.prysm-pyrmont.dappnode:4000

Does anyone have any ideas on how to get around this? Thanks!