DappNodeXtreme preinstalled make home network herratic


I recently received the DappNodeXtreme preinstalled. When I connected it and switched it on worked fine. I could connect to it via Wifi fine. It also finished syncying the Ethereum network, but now it continues to take down the entire home network both lan and WiFi and I need to keep it disconnected to avoid that. I tried to restart it via wifi, but if I do so instead of restarting it takes down the network. The DappNode is connected to the router via cable and I access to it via WiFi with my laptop. At the moment it should not really doing anything at all since I had no time even to start to test the eth test network. I really hope you can help, I chose to buy a preinstalled dappnode to make my life easy, but apparently is not so easy, I’m not very experienced.

I investigated better and I understood a little more. Please understand I’m a ultra beginner. Actually DappNode is still syncing Geth, but why it takes down the entire home network? Is there some way to prevent that? my bandwidth is pretty large, it cannot be that. I checked the error log and it did not record any error during the last network failure.

Hi @aldaril79 and welcome to our Community Forum!! :hugs::muscle:

We think this can be related with some mischievous routers that from time to time may misbehave.

Let’s try the following:

  • Go to Packages > System Packages > IPFS
  • Click on the pause button
  • Reboot your router. Wait until you make sure it is fully rebooted.
  • Then go back again to the IPFS package (last screenshot) and click on Restart

Don’t worry, we are here to help and make things as easy as possible!!

This should bring things back to normal! :wink:

Thank you very much Ruvenni! I’ll check this out. Now I don’t manage to connect to the dappnode at all.

I wanted to add that it did not do this.

This cannot be the problem now I got a better idea.

Now DappNode is unreachable. Home WiFi still seems unstable.

Shall I switch off the dapp node with the button.

Is there a way to connect directly to the dappNode without having to go through DAppNodeWIFI? It is clear that the DappNode is running, most probably doing nothing is just unreachable.

Before restart it was giving Geth fully synced, than I restarted I saw that it was syncing, like there was unfinished work. Then home network went down, then home network came up again, than DAppNodeWIFI disappeared.

ruvenni, DappWIFI is down, dappnode seem running.

At home I can use a win10 laptop which access the Homewifi and it could also see the dappnode wifi. I have a linux machine connected to LAN, with ubuntu that I can use to connect to the dappnode via ssh if possible and/or useful. My mobile phone. Now there is no way to get in contact with it. It seems in the link that I attached that is possible to connect via OpenVPN, that I installed but I don’t know where to find the *.ovpn file. I saw the bar code that you sent with the device but I don’t understand how to use it.

What if the machine is defective? Is that possible? Am I supposed to access the dappNodeWiFi even if is not connected to the router?

@ruvenni please look the above.

Something which is very strange is that my router does not see the dappNode. Is that normal, it sees all my other devices but not the dappnode.

@ruvenni now it works, but I don’t think I did not do anything successful. I want to summarize all the questions that popped up to my mind. If you don’t know please tell me I don’t know.

1- It seems that now is working differently, i.e. when I connect to DappWiFi it cannot connect to standard websites. I think that is good but why it was different before?
2- The dappNode does not appear among the devices connected to the router when I look on the router. Why is that? Is that a problem?
3- It has happen and maybe it will happen in future that the dappnode is up but its DappWiFi is not available and the only thing that I can do is to manually restart the dappNode. Is there a way to connect directly to the dappnode without using the WiFi, I feel uncomfortable to relay on something unstable.
4-My feeling is that the change is very much related to the fact that it fully synchronized Geth, am I fooling myself?


This is a really “solo” chat

Hi @aldaril79

I’m afraid you should have done it right after ending the set-up steps here https://welcome.dappnode.io/

Yes. Step three on the above set-up guide lets you create VPN connections to access DAppNode from you favorite devices.

We provide a UI, the DAppManager, so no SSH or technical background should be required to use a DAppNode. But it is up to you in case you are familiar with Linux + Docker. We are Open Source after all!!! :wink:

This is also part of the set-up steps here https://welcome.dappnode.io/ (step 3)

If you mean the plastic card it contains your Nodler ID. Use the forum search to find out more about it.

Regarding your questions:

You should be able to browse normally AFAIK.

Sometimes routers firmware or user interface are not very reliable. ISP’s do not really care for them.

You’d better set-up some VPN connections to your favorite devices instead of using wifi.

Thanks for letting us know, it’s the first time someone has reported it so we don’t really know.

Hope this helps! :+1:

@ruvenni, thank you very much. I will install VPN (I actually done it already the only problem was the *.ovpn file). Why don’t write it somewhere in the package that you send at home? That whould be very helpful indeed… you know for dummies like me :wink:

1 Like

Ok… you have just indicated me that was already there… I don’t know. I will check tonight.