Dappnode No connect to Avax Wallet

Avalanche Dappnode won’t connect to my wallet. I used to be able to enter my wallet via Dappnode public. Now I just get a permanent connecting… connecting. Any ideas what’s wrong please? I tried on Discord but no answer on support or Avalanche thread.
The Avalanche explorers say I’m connected but I can’t get into my wallet. If I use Mainnet then it’s no problem.

Hmmm I’d have hoped for a reply within 4 days. I tried in Discord too… no luck. I’m still not connecting to public Dappnode.

Hi there my friend!

Sorry for the delay response, have been busy days with the new release

The problem you had quite probably was caused with the release. There was found an error on how domains was resolved and a new "hot fix " release should fix your problem.

Are you still experiencing the same issue?

Check that your dappnode is updated

Thanks for your reply. I had a feeling you were all busy. It’s nice to have anyone to get help from. One must be patient I know.
I just updated Avalanche and Dappnode Core as they were showing need of updating.

It still won’t connect to Dappnode Avalanche Wallet.
I just reset my router too. Is the URL correct as per previous photo. It’s trying to connect. I haven’t changed any settings.

Well I’ve got my wallet connected after restarting a second time after the update. I’m still not 100% sure if the world ca see me. What worries me is that Allnodes says I’ve been “disconnected” for 48 days. However Avascan, Vscout and Avaxdev all show I’m up. What’s the problem with Allnodes… or are all the others reporting my node wrong? I’ve also tried to run curl to see if my node is up but it says connect refused. I have visions of getting to the end of my validation period in a few months and it will say “No reward you weren’t online!” It’s just not good GUI not knowing what’s happening exactly happening. image


I think there was a recently update in Avalanche that breaks the UI, @tropicar is working on it. I will ping him to keep responding on this forum thread

1 Like

Can you go to http://my.dappnode/#/packages/avalanche.public.dappnode.eth/network or Packages > Avalanche > Network, click on the work near of Service and choose Avalanche, then write down the container IP.
If you are connected to the you will be able to do do:
curl -X POST --data '{ "jsonrpc":"2.0", "id" :1, "method" :"health.getLiveness" }' -H 'content-type:application/json;'

Where i wrote change it for the container IP you wrote down. YOu have to see something like:
About allnodes, I will ask for avax team, the first team told me that it was a problem related to allnodes and others validators had that problem too. Anyways I will inform you when they make me know.

About not be able to connect to the wallet, if that curl works you should be able to connect it . I need to see the logs to see if something is bad with the node.

I get failed but my node is used for the wallet… it works.

Important you must be connected to the VPN or using the cli of the dappnode machine.*
Try to ping the IP container you have obtained on the packages> avalanche > Network container IP.
If the node is running(the container is up and you can check de logs), even if is not working correctly, that answer makes no sense, sure that IP is the correct and you are connected to the VPN .

1 Like

Ok we’ve found the problem. I had the WALLET IP in not the AVALANCHE IP in the curl. I didn’t know which one to enter. Thought they were the same. It might be an idea to make the Avalanche choice appear FIRST in the drop down list. Change “7” to a “9”

My Postman works again too. It says I have 853 peers. Does this look healthy?

Allnodes still says I’m DISCONNECTED though. Thanks for your help again…

When I use “is my port open” it return “No…” I’ve opened it in router settings.

Thanks for your help again…:+1:



1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.