Consequences of using a router without NAT loopback


Like many, I have ran into the issue of not being able to download the OpenVPN profile upon initial setup because my router does not have a NAT loopback feature. Connecting directly to the node IP solved the issue.

Now in the diagnosis screen of the DAppNode, it still shows an error saying No NAT loopback, external IP did not resolve but I am not clear if this needs to be solved on my end for the long term (like getting a new router).

What are the actual consequences of running a node on a router without NAT loopback? Is it only a problem for downloading the VPN profile? Should I expect other issues when running DAppNode packages? Is it recommended to fix this issue or can one live with it?



NAT loopback feature is mostly used to solved VPN connection issues, such as connecting to your DAppNode from the same network via VPN. If you just connect to your DAppNode via wifi you should be okey. It has nothing to do with any other issue.

For more information you could go to DAppNode documentation and check for what is NAT loopback used: in the troubleshooting guide and the the frequent asked questions

Thanks for clarifying.

I was mentioning this since it shows as a red error in the UI which makes me think that something critical is not functioning well. I guess perhaps we could change the color to orange to signify a warning. I will provide this as a UX feedback.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.