Can't access discord

I was in the middle working through a problem I was having on the support channel then the screen glitched and the dappnode discord server vanished. I tried using the invite link on the website and that didn’t work. I created a new account and the that didn’t work either. I used my wife’s phone to create an account with her credentials and the same thing happened. I can join, but as soon as I agree to the rules of the server it glitches me out.

Discord support has not been helpful. My business and personal funds are utilizing Dappnode for staking and I cannot access the discord server with any account for two weeks. Not sure what happened. Can someone post this in the support channel on discord for the moderators to help me rejoin?

I can see in the forums that this has happened to other people before, but they didn’t receive any help.

Resolved, ChuyGarcia.eth sent me a new invite link that worked.

**If you have the same problem as me try this invite link: Dappnode

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.