Cannot connect from external device

I cannot connect from an external device to the DAppNode. I can through in my own network. The UI shows me “No NAT loopback, external IP did not resolve”. Fritzbox 7530 does not have this feature. I tried to add the public and internal IP to the DNS rebind protection exceptions in the router network settings. Does not work. Any suggestions?

Core DAppNode Packages versions

  • 0.2.6
  • 0.2.40, commit: 6838be01
  • 0.2.14
  • 0.2.8, commit: f9a8743e
  • 0.2.6

System info

  • dockerComposeVersion: 1.25.5
  • dockerServerVersion: 20.10.2
  • dockerCliVersion: 20.10.2
  • os: debian
  • versionCodename: bullseye
  • architecture: amd64
  • kernel: 5.9.0-4-amd64
  • Disk usage: 29%

Its seems like my ISP is blocking inbound traffic. At least it looks like this when doing a tracing.


There are several ways to connect to your dappnode:

  • DAppNodeWifi
  • Local network discovery
  • Openvpn
  • Wireguard

I assume you are trying to connect to your dappnode using either of the VPN methods (Open vpn and wireguard). In the wireguard method there is a credentials called “Local credentials”. These credentials have been designed to solve NAT loopback issues, could you try with them?

Also make sure you have opened ports and mapped to your dappnode (enable UPnP in your router), you have a view available at support > ports to scan the status of your ports.

The problem doesnt exist anymore. Thanks anyway for trying to help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.