Can' connect after installation from a script


I made an installation from a script on ubuntu 20.04. Unfortunately I can’t connect to my dappnode thru the link given at the end of the installation.

And here are the last lines in the terminal before the QR code

Does anyone know what means “input device is not a tty”? And also it says wifi is not detected but i am connected to my rooter with an ethernet cable…

I am sorry I am pretty new to all of this and don’t understand everything, any help is welcome :slight_smile:

Thanks, have a good day.

hi there!

There are 3 differnet ways to connect to your dappnode, check them out at

Seems like the way you are using is Open VPN which needs a few ports opened on the router. These ports are automatically opened by your dappnode but your router must have UPnP enabled. Make sure you have it

However, I encourage you to connect to your dappnode through the DAppNodeWIFI. Scan for wifi networks and connect to the DAppNodeWifi using the default password dappnode

Hello Pablo,

thank you for your answer.

So I tried the installation a first time (UPnP is enabled on my router).

For some reason access to the UI thru local network or Wifi are not working. Then I decided to try the VPN solution and it worked, I reached the UI, but then when i was connected on dappnode UI my internet stopped to work as reported in this article:

Also I found out that my router has no nat loopback if this is an important information.

So since I was stuck with this network problem I decided to uninstall and try again a new installation. But now at the end of the installation I don’t even get the VPN link or the QR code (see the screenshot) so i can’t reach the UI this way, and local network and wifi still don’t work so I am fully stuck.

Any suggestions about what i can do to get back the link to the vpn file at the end of the installation? or fix another way (wifi, local network) of connecting?

Thank you, cheers

Hi there!

  • Try local network by connecting to the same router as your dappnode is and in the browser go to http://dappnode.local

  • The dappnode wifi should work! try executing docker restart and connecting again

  • For VPN: you have wireguard, to get your credentials execute dappnode_wireguard (with --qr flag for QR format)

Hello Pablo,

Thank you for the reactivity.

So i connected thru wifi on my router to access dappnode.local however i can’t connect I have a 403 error:

Also since i did connect to my local network thru wifi i can’t access wifi setting on my desktop anymore for some reason:

It happened right after i tried the local network connection.

I restarted the wifi docker but even tho I can’t find the dappnode wifi either on my desktop or on my phone.

Where do i need to execute the command dappnode_wireguard --qr? in a classic terminal it says command not found:

Let me know what you think. Last time I connected thru openVPN getting the QR code at the end of the installation, any idea on how I can get the QR code again?

Thanks lot, have a good day

If you installed DAppNode on a machine and you want to access the UI directly from the same machine there is a step way more easier, just access the dappmanacer container IP. To do that go to:

To access your dappnode through wifi, local proxying or VPN you should use an external device and not the same machine where dappnode is installed

Hi Pablo,

Thank you very much, indeed it gives me access to the UI. I am going to start experiencing with it!

Have a good day.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.