Beginner setup problems

Hi, so I will list out the steps I’ve done to hopefully describe where I’m at and hopefully help someone help me:
So I purchased the Dappnode Advanced, hooked it up to my wifi router via an Ethernet cord. Was able to download the .ovpn profile to my Windows 10, I was having trouble getting the ovpn but once I disconnected my windows computer from the internet and was only connected to the dappnode wifi, I was able to get it.

I had and am still having trouble connecting to open vpn, my Upnp is turned on. However I noticed while my windows was still disconnected to the internet I tried searching mydappnode and was able to connect to the dashboard, it made me think the vpn thing wasnt even necessary if the device is able to connect to the dappnode wifi to begin with.

So once in the dashboard, (no vpn connected at this point) I was prompted to change the dappnodes host password (I did this and the change is still there) and it asked me to change the wifi name and password for that. Which I did.

However when trying to use the dappstore I was unable to connect, I found the diagnostics tab that said there was trouble with the ifps or something like that, I then looked through forums and saw someone mentioned updated the dappnode fixed it, so I found how to do this through the command prompt.

The updates were successful and I wanted to restart the NuC for the updates to take. So I typed reboot or sudo reboot, then once I went back on my windows I noticed the dappnode wifi name reverted back to its old name and I can no longer connect to the dashboard at all. I checked the dappnode and it looks like my host password change stayed and the updates stayed,

In conclusion: now I cannot connect to the dashboard and I still have never been able to connect to VPN.

There are a few things to take into account before going further with your issue.

  • Even having UpNp enabled, sometimes the router do not have the necessary ports open by default. Could you log into your router and verify that the following ports are opened:
      • 8092 TCP: port used to correctly download the ovpn file.
      • 1194 UDP: default port to connect via OpenVPN.

There are two different ways you can reach back to the UI:

  1. Plug a monitor via hdmi and a keyboard
  2. ssh into your dappnode

Related to the ipfs issue, it is a package needed to interact with the dappstore, so make sure that it is running with no issues by going in the UI to packages > system packages > ipfs . If necessary restart the package, take into account that the ipfs package may consume high bandwidth rate

Hey Pablo, thanks for the reply, how do I check those ports? The closet thing I can find is through my internet providers mobile app, under advance settings there is something called Port forwarding and IP reservation and choose my comp and it gives me this option

Or are those settings found somewhere in my windows computer?

I do have a monitor and keyboard attached to my dappnode and can see the QR code in some kind of bios menu (not familiar with linux) are you saying there’s some kind of way to leave that bios menus and go to the dappnode UI/dashboard? @pablo

So I’ve got the ovpn package, I’ve got “openvpn connect” upnp is on, port assignment thru my router for my desktop has udp 8092 and tcp 8092 assigned , but still unable to connect, really hoping someone can help me, it’s upsetting for something that was for the most part suppose to be plug and play out of the box to give such a hard time setting up. Any help greatly appreciated

You can access your router and verify that 8092 TCP and 1194 UDP are opened (both of them), you can follow this guide if you are not familiar on how to access your router.

Once opened you should be able to download your vpn file and connect via VPN.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.