Prysm Pyrmont - Validator/accounts 500 Internal Server Error

I had an issue similar to the below linked issue, but now a new one with getting started as a validator in pyrmont testnet

I can now get into the PrismWebUI, but I get an error when I click on “Account List”

Http failure response for http://prysm-pyrmont.dappnode/api/v2/validator/accounts?pageSize=5: Internal Server Error


Should I just delete prysm pyrmont and reinstall it?

Core DAppNode Packages versions

  • 0.2.37, commit: 2b96e582
  • 0.2.41
  • 0.2.7, commit: 12ae223f
  • 0.2.5
  • 0.2.12
  • 0.2.6

System info

  • docker version: Docker version 18.09.8-ce, build 0dd43dd87fd530113bf44c9bba9ad8b20ce4637f
  • docker compose version: docker-compose version 1.25.5, build unknown
  • platform: linux, x64, 5.9.0-4-amd64
  • Disk usage: 341020403302

if I remember correctly either your validator was still pending state or the eth1 hasn’t finished syncing yet. Can’t remember which issue it was.

Thanks for the suggestion - It says the eth1 is synced, but maybe i should restart that and see if it helps

I’ve uninstalled prysm and started the deposit_data import sequence a few times now. Still can’t successfully get my wallet password accepted.

Just in case I had written down a password incorrectly or there was a problem with the .json file, I deposited another 32 gETH and went throught the steps and still can’t get a success at the wallet password

password is over 10 letters, 1 special character, 4 numbers

So I might restart the eth1. Also am in Singapore, maybe the clock sync is an issue. Thinking out loud.


That is very awfull. I have the same problem, but having been already deposited 32 eth to deposit. So I guess I’m already is being chraged with penaltise because Dappnode does not work properly. I’ve raised two issues to the support.
And I have ETH1 synchronised, the system is up todated :frowning:
There is no any other ETH2 validator in the DappStore.
I’m trying to install Lighthouse as emergency solution, but it’s not easy as the linux version is not fullfilled with all libraries and have to update everything

the solution is here

Thanks for the suggestion Alhimik

Unfortunately, hasn’t worked for me if I ensure I only upload the keystore .json file.

Still get the following when I try to enter the new wallet password

I’ve uninstalled prysm pyrmont and will leave it overnight before re-installing and trying again tomorrow, maybe that will help

I have probably uploaded the deposit data file in the past. I wonder if I need to find this somehow and delete it?

Tried what I was thinking above. Still doesn’t work for me

Anyone got any ideas?

Hi @jono

Make sure to have DAppNode auto-updates enabled or manually update by clicking here

Try to follow the solutions posted here

  • Set the password as stated here in our guide
  • Be careful to only upload deposit.json alike file to the Prysm UI as shown here and here

Thank you @ruvenni - Tried all of the suggestions including activating auto updates. Left the system alone for a couple of days and tried again. This time it worked, so now the validator was fully set up and attesting well. Much appreciated, and one more step towards mainnet. Appreciate it.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.