No admin privileges for Admin UI on clean install


I’m getting an error that I don’t have admin privileges, after a clean setup on ubuntu. Using the default network manager, following the guide at

I did get the QR code and link. Downloaded the .ovpn file and added it to my networks. After connecting and going to my.dappnode I got the ‘Snap’ message that I don’t have admin privileges.

I tried to uninstall and install dappnode again afterwards. Figuring I might have missed something. But the second install didn’t show a QR code anymore, but ‘admin credentials expired’.
I tried to run the command ‘dappnode_get dappnode_admin’, but not got a command not found.
Then tried via docker: docker exec -ti vpncli get dappnode_admin

But received:
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.40/containers/ dial unix /var/run/docker.sock: connect: permission denied

Not sure what to do next.

  • What OS are you connecting from?
  • What IP is the VPN assigning to you?

To get a new QR code, your user needs to be added to the docker group:

sudo usermod -aG docker $USER

then you can try again.

I was trying to connect to it from the machine itself. Ubuntu 20.4.

After adding my user I can indeed update my admin (dappnode_admin), which generates a new QR-code/link. When trying to visit though, I get a ‘NetworkError when attempting to fetch resource’.