Issue connecting Eth2stats to Medalla beacon chain

Continuation of this thread but for Medalla instead of Altona.

I am running the latest DAppNode ISO with the Prysm Beacon Chain and the Eth2stats client packages.

The logs indicate that the default Eth2stats config parameters cannot resolve:

BEACON_ADDR = prysm-beacon-chain.public.dappnode:4000
BEACON_METRICS = http://prysm-beacon-chain.public.dappnode:8080/metrics

I’ve tried changing them to:

BEACON_ADDR = goerli-geth.dappnode:4000
BEACON_METRICS = http://goerli-geth.dappnode:8545/metrics

and get “connection refused” and “[metrics-watcher] could not find ‘process_resident_memory_bytes’ in metrics” respectively for these two settings in the log.

So for reference, the answer appears to be:

prysm-medalla-beacon-chain.dappnode:4000
http://prysm-medalla-beacon-chain.dappnode:8080/metrics
1 Like

Update 12 August 2020: The eth2stats package included available in DAppNode is v0.1.1. Latest Github is v0.1.2. It looks like at least the v0.1.1 package is still pointing to the Topaz/Sapphire testnets, and returns a 404 error in the logs when trying to connect to the eth2stats RPC. So for now I am unable to use the eth2stats client package with Medalla. The Medalla URL appears to be hardcoded and can’t be edited through the DAppNode GUI for the eth2stats client. I guess the workaround for now is to run the eth2stats client docker separately as per https://eth2stats.io/add-node.