Disable Wifi System Package


Is there anyway to disable the Wifi System Package? Mine is stuck in a restart loop. The hardware I am running dappnode on does have a wifi card (wlan0) but it does not support AP mode so it fails.

Core DAppNode Packages versions

  • dappmanager.dnp.dappnode.eth : 0.2.32, commit: 6e10ba53
  • core.dnp.dappnode.eth : 0.2.36
  • ipfs.dnp.dappnode.eth : 0.2.9
  • admin.dnp.dappnode.eth : 0.2.20, commit: 0cee5543
  • wifi.dnp.dappnode.eth : 0.2.3
  • vpn.dnp.dappnode.eth : 0.2.5
  • bind.dnp.dappnode.eth : 0.2.4
  • wamp.dnp.dappnode.eth : 0.2.2

System info

  • docker version : Docker version 18.09.8-ce, build 0dd43dd87fd530113bf44c9bba9ad8b20ce4637f
  • docker compose version : docker-compose version 1.24.1, build 4667896b
  • Disk usage : 26%



Or even uninstall it!

Yup uninstalling it would be good too, if possible.

The WIFI package can be stopped.

However, it will be enabled again after a reboot, so a feature to completely disable it (and other packages) would be nice.

Feel free to add such feature request here, so we add it in the future !

1 Like

I’ll do that, thanks!

1 Like

In this context would also mention: https://github.com/dappnode/DNP_ADMIN/issues/440