Dappnode_connect fails with "no hostname returned"

dappnode_connect fails on an Intel NUC with wireless internet connection with the error message as in the PR below (“no hostname returned”). Any advice would be appreciated. Thanks.


I am working with 0.2.37. Is there already a 0.2.6?

I switched from WiFi to ethernet. That resolved my issue. I now get the QR code.

1 Like

But the QR code URL fails to open. Both my DAppNode NUC and laptop are on ethernet.

Hi @josefansinger

As long as you keep the ethernet connection and your router has Upnp enabled it should grant you access to the URL, and there you could download the .ovpn file.

Do you know or can you check if Upnp is already active?

Thank you. Reading the docu that might be the problem. https://dappnode.github.io/DAppNodeDocs/install/ How can I open/forward manually?

Maybe you should have a look at this section in our troubleshooting guide: https://dappnode.github.io/DAppNodeDocs/troubleshooting/#i-cant-access-the-credentials-otp-web-link-to-download-the-ovpn-file

Let us know if it helps

I opened TCP 8090 and UDP 1194 on my router. Still cannot download the *.ovpn file from the QR code.

I upgraded my router hardware and enabled Universal Plug and Play (UPnP) which wasn’t possible before. Still cannot download the *.ovpn file. Both NUC and laptop are connected to the router with ethernet.

Hi @josefansinger

Sorry for the delay. It seems our documentation it’s not accurate about the TCP port number. It says 8090 but the right one should be 8092 instead.

I’m setting an internal request to update it asap. Sorry if this has caused you any inconvenience.

Let us know if opening the right port number solves the incident.


Just letting you know the documentation was fixed yesterday. Now it shows the right TCP an UDP ports.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.