Connecting Metamask Chain ID error

Having issue connecting Metamask to my node.

I am getting an error that "The endpoint returned a different chain ID: 0x0

Same error as in this thread but the issue says its resolved in 2.36, I’m running a later version but still having the issue. I’m new to DAppNode as well but so far all the instructions have been easy to follow, just stuck here.

Thanks for the assistance!

Core DAppNode Packages versions 0.2.37, commit: 2b96e582 0.2.7, commit: 12ae223f 0.2.5 0.2.6 0.2.14
System info
docker version: Docker version 18.09.8-ce, build 0dd43dd87fd530113bf44c9bba9ad8b20ce4637f
docker compose version: docker-compose version 1.25.5, build unknown
platform: linux, x64, 4.19.0-13-amd64
Disk usage: 193166154138

Same here. I’m still having this issue.

A user has already reported the same issue (i think).

If Im right you follow the instructions available in dappnode documentation.

Instead of using the url you can see in the image above, use the following:

Or if you run a full node you can use:

I tried that as well, same result.

what chain id mean ? what should we put there ?
We can not add our full node without it and there are no explanation in the doc !

The way of connecting metamask has recently changed so DAppNode documentation is out of date, will be updated soon.

I will let you know with the updates.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.