Can't get more than 1 or 2 peers in geth and 0 inbound peers but 45 outbound for Prysm

Core DAppNode Packages versions

  • 0.2.6
  • 0.2.52
  • 0.2.47, commit: 35c4a081
  • 0.1.3
  • 0.2.15
  • 0.2.8
  • 0.1.1

System info

  • dockerComposeVersion: 1.25.5
  • dockerServerVersion: 20.10.6
  • dockerCliVersion: 20.10.6
  • os: debian
  • versionCodename: bullseye
  • architecture: amd64
  • kernel: 5.10.0-12-amd64
  • Disk usage: 23%

My validator: Ethereum 2.0 Beacon Chain (Phase 0) Block Chain Explorer - Validator 283024 - - 2022 (the misses are from me rebooting validator/restarting router)

Using Goerli Geth and Prater Prysm, can’t seem to pin down the problem (refer to post title). It’s resulting in some pretty abysmal inclusion distance spikes (ruining my effectiveness). All ports detected in dappnode seem to be open when I run both the UPnP and API scan, but I cant seem to get my router to open 30303, 13000, or 12000 even though I manually opened them, testing says theyre still closed (dont know how much this matters). My firewall on the router is set to allow WAN inbound so that shouldn’t be the issue either. I also tried --p2p-host-ip=myexternalIP under EXTRA_OPTS in Prysm which didn’t fix my inbound peer issue either (the logs when restarting say its “inaccessible”). Also made it DMZ which didn’t change anything. Could this be an issue with my ISP (Spectrum doesnt have cgnat, I checked) or router (I know the router is pretty old)?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.