Cannot connect to DappNode from Raspberry Pi on same network

Hi all,

I’m really struggling to get a connection running from my (headless) Raspberry Pi to the Physical DappNode on the same network. As far as I know, I’ve managed to open the OpenVPN connection, and it’s showing as active. However, when I try to run a python web3 script to test the connection, it shows that I’m not connected. Help would be appreciated. Here are the details:

  • I installed openvpn and network-manager on the pi
  • In the dappnode admin ui I added a device, and downloaded the .ovpn file to the raspberry pi
  • I imported the ovpn file with - sudo nmcli connection import type openvpn file ~/dappnode.ovpn
  • nmcli connection show shows the vpn connection set to active:
NAME                UUID                                  TYPE      DEVICE
DAppNode            396901d7-9813-44ec-aa4b-f0240b49e6bb  vpn       eth0
Wired connection 1  3a7eade5-0bdf-37f7-8bee-aeb2900994a7  ethernet  eth0
tun1                6cdb1697-1ecb-4d83-a6f9-b9994fe22ab7  tun       tun1  

I feel like everything is setup properly, but cannot figure out for the the life of me, why I’m still not able to get an active connection when I run the following python web3 script:

from web3 import Web3, HTTPProvider, WebsocketProvider

ws = 'ws://fullnode.dappnode:8546'
rpc = 'http://fullnode.dappnode:8545'

web3_ws = Web3(WebsocketProvider(ws))
web3_rpc = Web3(HTTPProvider(rpc))

print(web3_ws.isConnected()) # False
print(web3_rpc.isConnected()) # False

I’ve been searching and trying out a lot of stuff, but really don’t know what I need to do to further troubleshoot this issue. any ideas are very welcome!


1 Like

Hi @whatsYourPickle,

Thanks for reaching us with this question. Let us check it internally and see how can we help you :wink:

Hi @ruvenni, thanks! any input yet? Still trying to get this working…
And now with the Infura issues, it’s all the more important :frowning:

I understand that the info I gave is probably not enough to know what’s wrong, but if you let me know what info you need (and how i can get it), i’ll share it asap.


Alright, so I’ve continued to try to fix this, but still no luck. Here’s more details about what I did and what I’m seeing:

  • A setup an entirely new Raspberry Pi with Raspbian Buster, just to be sure no existing configs or whatever are messing it up
  • If I connect to the DAppNodeWIFI everything works fine. I’m able to access the my.dappnode Admin page as well as run my python web3 script interacting the local DAppNode
  • I however cannot get it working when not connected to the DAppNodeWIFI. Here are the steps that I followed:
  1. On my router I setup port forwarding for ports 8090 and 1194 for the Internal IP of my DAppNode server
  2. Installed openvpn using sudo apt-get install openvpn
  3. Created a new device in the DAppNode Admin panel for my Raspberry Pi and downloaded the .ovpn / .conf file (I named it DAppNode) to the Raspberry Pi folder /etc/openvpn/client
  4. Started the openvpn connection using sudo systemctl start openvpn-client@DAppNode
  5. If I check the status of the connection using systemctl status openvpn-client@DAppNode, everything looks fine. It’s shown as active (running) and shows Initialization Sequence Completed and that there is a peer connection initiated with the internal IP address of my DAppNode server
  6. Internet and everything works fine, I’m able to connect to sites are usual. However, I’m not able to access the DAppNode Admin page, nor does my python Web3 script work. i.e. I’m not routing ETH traffic over the DAppNode it seems

Hi @whatsYourPickle,

To be honest this is a very singular use case, and we have no previous experience about it but I have some point that might be useful:

  • You can try to traceroute and see if you get a similar output

$ traceroute my.dappnode
traceroute to my.dappnode (, 64 hops max, 52 byte packets
1 ( 40.718 ms 41.053 ms 40.862 ms
2 ( 41.298 ms 42.242 ms 41.003 ms

  • You can also dig to the local DAppNode DNS (wich is a DNP package) called BIND, and compare the result if you just dig to my.dappnode. Like this:

$ dig my.dappnode @

and then

$ dig my.dappnode

They should give you the same output, otherwise there might be a problem in how you laptops is doing the domain-name resolution.

I hope this rings a bell!!!

Did you fix your problem ?

no, still not fixed unfortunately. Really have no idea how to troubleshoot this, nor where to look for help… So a bit helpless now.

I wish DAppNode provided better documentation. The documentation is good for what’s available out of the box, but as soon as you want to go 1 level deeper and do a bit of customization, there’s no info and you’re left on your own.

SOLVED :white_check_mark:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.